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Welcome to Substitute Teacher Service
On Line Information Systems

Installation and Instruction Manual
District Teachers

This manual has been revised as of 1/1/2010
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BEFORE YOU BEGIN …

Get your registration code from STS first! 
Send an email to:
loginhelp@thesubservice.com.

Include:
Your Name
School District
School Building
Grade/Subject you teach
Email address
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Computer Setup Instructions

The STSCS application is a Java applet that is downloaded from the STS server. In order for the 
application to run, you must have the latest version of Java installed on the computer or 
computers that will be running STS.

System requirements are as follows:
A high-speed Internet connection, such as T1, DSL, Cable, or FiOS. 
Note: Dial-up users (56K or less) will experience longer than usual wait times and 
connection time-outs and/or failures.  The system will run, but may operate at 
excruciatingly slow speeds.
Java Runtime Environment (JRE) version 1.6.0, or better, from Sun or Apple. (Most 
computers already have Java loaded on them)
Adobe Acrobat Reader 6.0 or better (for pdf-type help and tutorial files).
Any computer capable of running the Java Runtime Environment (JRE) from either Sun 
or Apple, including, but not limited to, Microsoft Windows, Apple Macintosh, Unix, Linux, 
or Solaris. Note: The Microsoft Corporation no longer supports certain versions of the 
Microsoft Windows operating system, including Windows 98, Windows 98 Second 
Edition, Windows NT and Windows ME.  Therefore, STS does not guarantee our 
application will function properly or securely on those platforms, although we make every 
effort to ensure our applications operate independently of operating system flaws 
wherever possible.

If you need to download Java, links are available on our download page. Go to 
http://thesubservice.net/register.pl  in the Installing or Updating Java section.

Once your system meets these requirements, you are now ready to download the STSCS 
application. Go to http://www.thesubservice.com and click on the Client Login button.

To Install:
1. To begin the download and/or run the application, click on the Client Login button.
2. One of two things will happen when you click the above...

a. A "download or execute" dialog box will appear.  In this case, choose to execute 
the application. 

b. A download-only dialog will appear.  In this case... 
i. Download the file to your desktop. 
ii. Double-click the downloaded file (on your desktop). 
iii. Continue with the instructions below.  After STS-CS is running, you 

should delete that file from your desktop (it will be of type JNLP). 
3. If you are asked if you want a desktop icon (depends on the operating system), answer 

yes.  If you choose no, you will need to go to the STS Home page each time to run the 
application.

4. You may be presented with a security certificate dialog after STS-CS downloads. 
a. If this dialog gives you the option to always trust this publisher, you should 

answer in the affirmative. This will prevent this warning from being displayed 
each time the application is run.

5. You will see a splash screen, and eventually be presented with a login form. You are 
now ready to proceed. Follow the instructions in the next section for completing 
registration. 

Note: Performance at this stage depends heavily on network issues.  If there are connection 
or performance problems, contact the STS system administrator at 800-357-7827 Ext. 250. 
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District Teacher Registration – NEW  

First you will need to launch the STSCS 
program from the desktop icon that was 
created. This process will only occur one time.

From the Login form, click on the Register 
button. 

You will then be presented with the User 
Registration form.

 If you are a district teacher, then click on the 
Teacher Registration button.

 If you are an STS employee, then click on the 
Substitute Registration button, and so on.

 If you do not wish to register , click the Close 
button. You will be taken back to the Login form.

To Exit the STSCS program, click on the Exit button on the Login form.

New Teacher Registration
You will need to have your registration code that was provided by STS. If you have not yet done 
so, you will need to obtain this information before you are able to use the system. Email your 
name, district, school and the grade/subject area you teach to loginhelp@thesubservice.com. 
You should get your registration code within 4 to 6 hours. 

In the mean time, if you need to request a substitute for your absence please call your local STS 
office. In Delaware, Chester, Montgomery, Bucks Counties and Delaware State, call 800-357-
7827. The Lancaster and Harrisburg Regions call 800-884-7827.

Once you receive your registration code, start up the STS application and click on the Register 
button. Click on Teacher Registration. You will be presented with a dialog box that will ask you to 
enter your Registration Code. Enter the code exactly as it appears in the email from STS. Include 
all dashes. If you leave the form blank, you will not be allowed to continue.
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Next, click the Next button. 

You will be presented with a dialog of what your Teacher record looks like in the STS system. 
You cannot change any of this information. However, if it does require a change, please contact 
your STS office. Click the Next button.

STS will process your information and create a login 
for you. When it has completed, you will this form: 

Please make a note of your login name. This is how 
you will access the system in the future. For security 
reasons, do not share your user information with 
anyone. You will be responsible for anything that has 
your user name assigned to it. Once you are ready, 
click Yes.
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System will now ask you to create a password. The password is 
case sensitive and can be any combination of alpha-numeric 
characters. Your password must be at least 6 characters.

Again, for security reasons, do not share your user information 
with anyone. You will be responsible for anything that has your 
user name assigned to it.

STS will not give your password out to you or anyone else 
inquiring about it weather it is by phone, fax, or email. If you 

loose your password, STS procedure will be to delete your account, and you will need to re-
register.

Enter your password and click Go. You will be asked to verify the password on 
the next form. Click Go. System will send back a message that the Password 
has been changed.

Click OK when done.

You will now be taken into the system.
Please see the Using STSCS tutorial for more information on using STSCS.

For your records: (please keep in a secure place)

Login Name:  __________________________________

Password:  ____________________________________

Date Registered:  _______________________________

Contact Information:

STS Media Office – General Information, Assignments, Etc. 610-566-6466
800-357-SUBS (7827)

STS Lancaster Office 717-391-SUBS (7827)
800-884-SUBS (7827)

Technical Support – email only – techsupport@thesubservice.com

Trouble logging in – email only – loginhelp@thesubservice.com
Emails will be answered within 24 hours.
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Using STS Teacher Version

To begin, you will need to know the 
login name that was assigned to you 
during your registration and setup. 
Enter into the User Name field. The 
Login button will now become 
highlighted. Click on it and you will 
be prompted for your password.

Click Go to proceed.

System will now load the form that you will do most of your work from. It is called the Call Slip 
form. From this form you will be able to place your requests for substitutes. The form will open in 
the Adding mode, populated with your information and assuming that you wish to put your 
absence on line.

The call slip form will default to the next day as the date of your absence. These dates can be 
changed by typing them in using the format mm/dd/yy or by using the plus (+) and minus (-) keys. 
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You will be required to put a reason on the form. If you do not wish to give one, then select “No 
Reason Given”. You can also leave instructions or request specific subs by entering this info in 
the Comments section.

Note for requesting or confirming subs: If you have spoken to a sub and he/she has agreed to do 
your position, type Confirm subname in the comments. Otherwise, type Request subname. If you 
do not need a sub, please type NO SUB REQUIRED in the comments.

Once you begin changing info, you will notice 
that the status changes to “Adding Changed”. 
To save your absence and assign it for filling, 
click on the Commit button. Use Save to save 
your workspace (this does not commit the 
absence for processing), and Cancel to kill the 
absence. If you have assigned Preferred Subs 
and you wish us to use them first, click on the 
Pref Subs button to view your list, and in the 
Comments, type something like “use my 
preferred sublist”

When done, check your work, make sure it is 
correct, click Commit.

You will notice that the status will initialize and return a blank Call Slip for you to use. System will 
also send you a confirmation message that your absence has been submitted for processing.
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Note the message light in the button area of the Call Slip. Click on the green MSG button to view 
the message.

This is what the confirmation message will 
look like.  Keep a record of the Dispatch ID 
and the date and time created. 

The message light on the Call Slip will go out 
once you’ve read your messages. Please 
note that messages are not stored nor can 
they be retrieved at your computer.

You can add Call Slips one at a time or if you 
are going to be out for a consecutive range of 
dates, set the From and To dates 
accordingly.  Example:

From 8/22/05 to 8/31/05 is a valid absence 
for 8 days. Weekend dates are not included. 
If you already have an absence recorded for 
a specific date, you will get the following 
error:
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Error Handling
Errors are recorded, cannot save. The actual cause of the error will be displayed in red in the 
lower right corner of the Call Slip.

Possible Errors:
1. Teachers cannot be on different Call Slips for the same time period.
2. Call Slip must have a Reason.
3. If you teach in different schools on the same day, you need to split your Call Slip so that 

one part reflects the AM in one building, and a new Call Slip reflects the PM in another.

Once you click OK, the Call Slip is returned to you in the Add mode for correction.

If you are finished with adding your absences, you can Exit the Call Slip by clicking on the X in 
the upper right corner. If you are in Adding mode, system will ask you if you want to Cancel New 
Record (the Call Slip on the screen). If you choose yes, you will Exit without saving, if you choose 
no, you can commit the absence on your screen to the system.

Other Features:
The Menu Bar
The File menu contains the following:

Send Message allows you to send a message to another STSCS 
user. (you will need to know the user’s login name)
Show Messages will display any messages that are directed to 
you.
Change Password allows the current user to change their 
password.
Operations Recovery – In a previous session, your work was in 
an incomplete state or your work was not saved.
Log off closes the current user’s session.
Exit closes the STSCS program.
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The Edit Menu – this is new as of 10/15/2006
The Edit menu contains 2 ways for you to look at your future requests. You can go directly to a 
call slip if you have the confirmation number, or can you view a listing.

The Find Screen
Important Note! Before using the Find or Goto features, click the Cancel button on the call slip 
form so that the Call Slip form is in the Display mode.

The Find screen will show a listing of all of the absences for you that are currently in the STS 
system. Put in the dates you want to view and click the Find button.

You can view the call slip by highlighting the line and clicking the View Call Slip button. You can 
print this listing by clicking the Print Find Report button.

If the absence is filled with a substitute, the sub’s name will appear in the Substitute name. If not, 
it will be blank or To Be Refilled. If you need to make changes to any absence in the list, contact 
your STS office.
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Using Goto
If you know an absence confirmation number, you can go 
directly to that call slip. Again, you need to make sure that your 
call slip is in the Display mode.

Key in the call slip (confirmation) number and click Go.
The call slip will be displayed in the call slip form.

The only options available when displaying a previously entered 
call slip is to Add a new Call Slip or Print out the current call slip 
that is on the Call Slip form.

The Tools menu contains the functions you will use to view any absence that STS has for you in 
the current system year.

Click on the Teacher Work History 
item. You will be presented with 
another form that will ask you for 
the dates you want to view. Then 
click on the Process button.

If no records exist, you will receive 
a message stating the Document 
has no Pages. Click OK to close 
the dialog, and then close the 
report window.

When there are pages, this is how the report will look like this:
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Saving the report will default the save to wherever your “My Documents” folder is located. You 
can also change the file type to pdf, doc, or whatever you choose to save the file as.

Printing the report will open the Print dialog box. Choose how and where you want to print to 
based on the options of your computer setup.

Email Reports. Not available in this version.

Other Report toolbar options are navigating through the pages using the navigation buttons, 
zoom using the zoom buttons, and viewing the report as a grid. 

Page Navigation Tool

Zoom (Enlarge/Reduce) Tool

View report as a Grid Tool

The Help Menu

If you should have any questions or problems, look in the Contacts section. Thank you for using 
STSCS.

The Report Form Toolbar

The Help Menu contains System and Program Information that may be helpful if 
required by an STS technican.

Who Am I? Gives you information about your login, location, etc.

Release History gives an overview of program releasing information, fixes, and 
updates.

Release Info gives information about the current version of software you are running 
and weather or not updates are required.

About STSCS gives information about the writers and owners of the software itself.

http://www.pdfonline.com/easypdf/?gad=CLjUiqcCEgjbNejkqKEugRjG27j-AyCw_-AP

